错误码
|
Error Code
|
Http Code
|
Error Message
|
|
Ecs.Region.EmptyRegion
|
403
|
The specified account has no access authority to any region.
|
|
Ecs.Region.DescribeError
|
500
|
Query region error.
|
|
Ecs.Zone.DescribeError
|
500
|
Query zone error.
|
|
Ecs.Zone.IdNull
|
400
|
Zone id can not be null.
|
|
Ecs.Zone.NotFound
|
404
|
Zone not found.
|
|
Ecs.Param.Invalid
|
400
|
The request parameter is incorrect.
|
|
Ecs.Flavor.DescribeError
|
500
|
Query flavor error.
|
|
Ecs.BootVolume.DescribeError
|
400
|
Query boot volume error.
|
|
Ecs.Instance.SpotUserNoAuthority
|
403
|
The current user has no authority for spot.
|
|
Ecs.Flavor.NotFound
|
404
|
Flavor not found.
|
|
Ecs.Instance.SpotInvalidHistoryPriceDuration
|
400
|
Invalid param duration.
|
|
Ecs.Authority.DescribeError
|
500
|
query authority error.
|
|
Ecs.Instance.SpotPoolNotSupport
|
400
|
The current pool not support spot.
|
|
Ecs.Param.Invalid.ZoneError
|
400
|
Invalid zone parameter.
|
|
Ecs.Throttling.Resource
|
429
|
The request throttle by resource operation.
|
|
Ecs.MissingParameter
|
400
|
The specified parameters are insufficient for current request.
|
|
Ecs.LaunchTemplate.NotFound
|
400
|
The launchTemplate not found.
|
|
Ecs.Authority.CustomerTypeNotSupport
|
403
|
The current operation is not supported for this customer type.
|
|
Ecs.Param.QuantityOutSize
|
400
|
The specified parameter quantity current ordered quantity 10000 exceeds the limit 500.
|
|
Ecs.Image.NotFound
|
404
|
Image not found.
|
|
Ecs.Image.NotSupportCurrentInstanceType
|
400
|
The image is not supported the instance type.
|
|
Ecs.KeyPair.NotSupportWindowsImage
|
400
|
Windows images not support keyPair.
|
|
Ecs.Image.NotSupportShareDataVolume
|
400
|
The image is not supported the share dataVolume.
|
|
Ecs.KeyPair.NotFound
|
404
|
The keypair not found.
|
|
Ecs.Tag.QuantityExceed
|
400
|
The number of tags bound to the resource exceeds the limit.
|
|
Ecs.Tag.KeyValueNotNull
|
400
|
The tag key or value cannot be empty.
|
|
Ecs.Tag.ECloudNotStart
|
400
|
The tag key or value cannot start with 'ecloud'.
|
|
Ecs.Tag.KeyNotRepetitive
|
400
|
The tag key bound to the instance should not be repetitive.
|
|
Ecs.Authority.Invalid
|
403
|
The user permission verification is invalid.
|
|
Ecs.Authority.NotStabilityPolicyAuthority
|
403
|
The current customer does not support filling in the CPU stabilityPolicy authority.
|
|
Ecs.Authority.PunishedUserNotAuthority
|
403
|
Users who have been punished are not allowed to perform this operation.
|
|
Ecs.PrivateNetwork.PrivateIpIsNotIpv4
|
400
|
When specifying an IP address, the IP is not IPv4.
|
|
Ecs.PrivateNetwork.PrivateIpIsNotSupportPortId
|
400
|
When specifying an IP address, PortId cannot be specified.
|
|
Ecs.PrivateNetwork.NetworkIdIsNull
|
404
|
NetworkId is not null.
|
|
Ecs.PrivateNetwork.PrivateIpNotSupportDualStackSubnet
|
400
|
The networkId has dual-stack subnets and currently does not support the creation of cloud hosts with a specific IPv4 address.
|
|
Ecs.PrivateNetwork.NetworkIdNotFoundSubnet
|
400
|
The subnet of the current networkId is empty.
|
|
Ecs.PrivateNetwork.SubNetIsNotOnlyIpv4
|
400
|
The subnet of the current networkId is not IPv4.
|
|
Ecs.PrivateNetwork.privateIdNotInSubnet
|
400
|
The privateIp not in current Subnet.
|
|
Ecs.PrivateNetwork.PrivateIdIsUsed
|
400
|
The privateId is used.
|
|
Ecs.PublicNetwork.EIpDuplicated
|
400
|
The specified eIpId is already in use.
|
|
Ecs.PublicNetwork.NotSupportEIpAndBandwidthSize
|
400
|
Fill in the eIp, and you cannot order a new public IP.
|
|
Ecs.InstanceGroup.NotFound
|
404
|
Group not found.
|
|
Ecs.Flavor.NotSupportVolumeType
|
400
|
The current flavor does not support the current bootVolumeType.
|
|
Ecs.ChargeImage.NotSupport
|
403
|
API is not support charge image.
|
|
Ecs.Flavor.NotOnline
|
404
|
The current flavor is not online.
|
|
Ecs.BootVolume.SoldOut
|
400
|
The current BootVolume type has been sold out.
|
|
Ecs.PublicNetwork.SoldOut
|
400
|
The current elastic public network has been sold out.
|
|
Ecs.PublicNetwork.BandWidthSoldOut
|
400
|
The current bandwidth has been sold out.
|
|
Ecs.PublicNetwork.Ipv6BandWidthSoldOut
|
400
|
The current ipv6 bandwidth has been sold out.
|
|
Ecs.DryRunOperation
|
200
|
The current request has passed the pre-check.
|
|
Ecs.SecurityGroup.DefaultInstanceSecurityGroupNotFound
|
400
|
The default instance securityGroup not found.
|
|
Ecs.Ebm.HourOrderNotSupport
|
400
|
Elastic Bare Metal currently does not support hourly billing.
|
|
Ecs.Instance.FlavorConvertFail
|
500
|
Instance specification conversion failed.
|
|
Ecs.Instance.CustomUserNameInvalid
|
400
|
The custom userName is invalid. Please refer to the parameter description.
|
|
Ecs.Volume.VolumeCapacityNotSupport
|
400
|
The remaining inventory of the selected volume resources in the current region is insufficient. Please adjust the order quantity.
|
|
Ecs.Instance.CreateFailed
|
500
|
Failed to create the instance.
|
|
Ecs.LaunchTemplate.CreateFailed
|
500
|
create launchTemplate failed.
|
|
Ecs.CpuOption.HyperThreadingDisableNotSupport
|
400
|
CPU topology type cannot be configured when Hyper-Threading is disabled.
|
|
Ecs.CpuOption.TopologyTypeNotSupport
|
400
|
The CPU topology type not support.
|
|
Ecs.Authority.NotDisplaySnAuthority
|
403
|
The current customer does not support filling in the displaySn authority.
|
|
Ecs.Instance.FlavorTypeNotSupportAutoInstallGPUDriver
|
400
|
The selected flavor type do not support automatic GPU driver installation.
|
|
Ecs.Instance.CurrentImageNotSupportTheGPUDriver
|
400
|
The driver version does not match the image. Please check and verify.
|
|
Ecs.Order.Exception
|
500
|
There is an internal order placement error. Please try again.
|
|
Ecs.Param.Invalid.InstanceIdIsBlank
|
404
|
The instanceId can not be empty.
|
|
Ecs.Param.Invalid.InstanceIdRepetition
|
403
|
InstanceIds cannot be repeated.
|
|
Ecs.Param.Invalid.InstanceIdsSizeOverLimit
|
403
|
The number of instance IDs exceeds the limit.
|
|
Ecs.Batch.RamUserInstanceNumExceedMaxSize
|
403
|
The num of ram user batch instances exceeds max size.
|
|
Ecs.Instance.DeleteFailed
|
500
|
Failed to delete the instance.
|
|
Ecs.Instance.IdNull
|
400
|
The instance id can not be null.
|
|
Ecs.Instance.NotFound
|
404
|
The instance does not exist.
|
|
Ecs.Instance.RenewOrderAuthorityValidateFailed
|
400
|
Failed to validate renew order authority of the instance.
|
|
Ecs.Instance.RenewFailed
|
500
|
Failed to renew the instance.
|
|
Ecs.Instance.DdhInstanceNotSupport
|
400
|
The instance on the ddh do not support the current operation.
|
|
Ecs.Instance.RenewIpv6SharedBandwidthNotSupported
|
400
|
Ipv6 Shared Bandwidth unsupported for unified renewal.
|
|
Ecs.Instance.AssociatedResourceNotSupportTurnAmount
|
400
|
Associated resources do not support renew turn amount.
|
|
Ecs.Instance.AssociatedResourceBillingMismatch
|
400
|
Associated resources do not support renew turn amount.
|
|
Ecs.Instance.OperationForeverDeny
|
403
|
The operation is permanently not allowed for the instance.
|
|
Ecs.Instance.ModifyChargeModeFailed
|
500
|
Failed to modify charge mode of the instance.
|
|
Ecs.Instance.ModifyChargeModeOrderAuthorityValidateFailed
|
400
|
Failed to validate modify charge mode order authority of the instance.
|
|
Ecs.Instance.BandwidthChargeModeDifferent
|
400
|
The charge mode of bandwidth is different from instance.
|
|
Ecs.Instance.BandwidthChargeModeAuthorityFailed
|
400
|
The charge mode authority of bandwidth check error.
|
|
Ecs.Instance.DataVolumeChargeModeDifferent
|
400
|
The charge mode of data volume is different from instance.
|
|
Ecs.Instance.DataVolumeChargeModeAuthorityFailed
|
400
|
The charge mode authority of data volume check error.
|
|
Ecs.Instance.EdgeRelatedNotSupport
|
403
|
The edge server do not support change related resource.
|
|
Ecs.BootVolume.InsufficientResources
|
400
|
Insufficient resources.
|
|
Ecs.BootVolume.OrderNotFound
|
404
|
Order not found.
|
|
Ecs.BootVolume.ProductTypeNotOnline
|
404
|
Product type not available.
|
|
Ecs.GetAccountBalanceError
|
500
|
Failed to retrieve account balance.
|
|
Ecs.AccountBalanceIsInsufficient
|
400
|
Insufficient account balance.
|
|
Ecs.BootVolume.TypeNotFound
|
404
|
Boot volume type not found.
|
|
Ecs.BootVolume.ChangeTypeNotSupport
|
400
|
Change type not supported.
|
|
Ecs.BootVolume.SizeLessThanOriginal
|
400
|
Boot volume size smaller than original.
|
|
Ddh.Cluster.IsFrozen
|
400
|
Cluster frozen.
|
|
Ddh.Cluster.NotFound
|
404
|
Cluster not found.
|
|
Ecs.Instance.ResizeBootVolumeFailed
|
500
|
Failed to resize boot volume.
|
|
Ecs.Instance.ResizeBootVolumeOrderAuthorityValidateFailed
|
400
|
Failed to validate resize order authority of boot volume.
|
|
Ecs.Instance.ModifyFeatureFailed
|
500
|
Failed to modify feature of the instance.
|
|
Ecs.Instance.InstanceNameInvalid
|
400
|
Instance name is invalid.
|
|
Ecs.Instance.ModifyFeatureInstanceNameDescriptionAndPasswordCanNotAllBeAllEmpty
|
400
|
Instance name, description and password can not be all empty when modifying feature.
|
|
Ecs.Instance.NameCanNotContainChineseCharacterWhenModifyingInstanceNameAndHostName
|
400
|
Instance name can not contain Chinese character when modifying instance name and host name.
|