云主机无法访问外网

一、网卡处于异常状态,ip地址设置错误

故障现象:云主机访问外网异常,无法访问网站、下载文件或者传输文件。

可能原因:

        1) 云主机不存在多网卡:虚拟网卡启用失败、配置多个ip地址、配置错误的IP地址、DNS服务器配置错误。

        2) 云主机存在多网卡:多网卡的优先级配置问题。

解决方法:

    1. 云主机不存在多网卡:Windows 操作系统。

        1) 登录移动云平台。

        2) 通过控制台,进行vnc登录订购的云主机。

        3) 输入用户名与密码进入云主机。

        4) 检查网络连接是否正常。

       image.png

        5) 在左下角,点击开始菜单,选择运行,然后输入cmd,然后按键盘Enter回车,使用ping命令检查网络的连通性与域名的解析。

       image.png

        6) 如果不能ping通,按如下方法检查一下网络配置或设置为自动获取ip地址。

       image.png

    2. 云主机不存在多网卡:Linux操作系统。

        1) 通过控制台VNC登录云主机操作。

        2) 使用ping命令检查网络的连通性域名的解析。

       image.png

        3) 使用如下命令查看网卡的状态与设置模式。

       image.png

        4) 检查并配置dns域名。

       image.png

        5) 查看是否配置网关路由,如果没有请使用route add default gw xxxx dev eth0 为自己添加相应的网关路由,具体操作可参考:Linux系统默认路由丢失导致连接或访问异常。

       image.png

    3. 云主机存在多网卡:Windows 操作系统。

    存在问题:云主机设置了多个网卡,访问外网时,优先选择了绑定私网IP地址的网卡导致云主机访问外网不通。

    解决思路:将绑定公网IP网址的网卡优先级设置更高,优先选择该网卡进行访问外网,更改网卡的接口跃点数,在对话框中不勾选“自动跃点(U)”,在“接口跃点数(N)”中填入数值(范围是1~9999),数值越小,路由选择越优先,用户预期想使用的那个路由的接口跃点数值必须是最小的。

        1) 进入网络和共享中心,点击“更改适配器设置”。

       image.png

        2) 选择要更改的网卡,右击,选择其“属性”,选择“Internet 协议版本 4 (TCP/IPv4)”,双击,或点击“属性”。

       image.png

        3) 进入新的对话框,点击“高级”。

       image.png

        4) 将“自动跃点(U)”不再勾选,下面的“接口跃点数(N)”中填入数字,如100。

       image.png

        5) 这样就把一张网卡的接口跃点数修改完毕,同样的方法可以修改另一张网卡,如把新增的网卡的接口跃点数改为200。

       image.png

        6) 在cmd界面执行ping 8.8.8.8,此时可以ping通。

       image.png

        7) 执行 pathping -n 8.8.8.8,这时使用的已经是初始网卡的路由。

       image.png

    4. 云主机存在多网卡:Linux操作系统。

    存在问题:

        1) 云主机设置了多个网卡,访问外网时,优先选择了绑定私网IP地址的网卡导致云主机访问外网不通。

    解决思路:云主机默认未安装NetworkManager,使用DHCP方式,可以在网卡配置文件中添加METRIC=xx参数(注意:每个ifcfg-eth配置文件均需添加此参数),并重启网络即可生效,默认值越小,路由选择越优先,用户预期想使用的那个路由的METRIC值必须是最小的。

  a) 找到网卡配置文件的位置。

  Ubuntu系统的网卡配置文件在:/etc/network/interfaces

  BCLinux、RHEL、CENTOS系统的网卡配置文件在:/etc/sysconfig/network-scripts/ifcfg-eth*

  b) 在相应的网卡配置文件中添加METRIC字段。

  image.png

  c) 重启网络服务,使网卡配置生效。

        2) 多网卡解绑、绑定导致访问异常。

可能原因:网卡解绑、绑定顺序造成网络异常。

解决方案:参考云主机多网卡解绑/绑定问题。

二、防火墙策略,拒绝连接访问,IE浏览器安全性过高,对敏感性网站拒绝访问

故障现象:拒绝访问外网。

可能原因:防火墙策略拒绝连接外网、浏览器安全性过高,拒绝访问。

解决方法:

    1. Windows操作系统

        1) 单击右下角【网卡】--【打开网络共享中心】--【windows防火墙】。

        image.png

        2) 适当开启或关闭防火墙,然后进行cmd,网络ping测试。

        image.png

        3) 选择高级设置。

        image.png

        4) 适当对防火墙里面入站规则与出站规则里面的服务进行开放或者关闭测试。

        image.png

        检查或开启需要访问的端口,点击高级设置。

  a) 找到防火墙开启的端口,开启或设置入站与出站规则端口。

  image.png

  b) 在远程 IP 地址菜单中勾选下列 IP 地址,单击添加。

  image.png

  c) 根据您的实际需求输入允许访问的 IP 地址,单击确定,再单击应用。

  image.png

        5) 检查IE浏览器设置,并适当设置IE降低安全性。

        image.png

        6) 安装使用第三方杀毒软件对云主机进行病毒查杀。

    2. Linux操作系统

        1) 检查selinux的状态:使用getenforce命令查询目前系统selinux状态,如返回为Disabled,则表示状态正常。如返回其他值,建议修改selinux配置文件,如下图所示,建议设置为disabled,需重启系统生效。

        image.png

        2) 检查是否安装或开启firewall、iptables防火墙策略,如若开启,可以尝试关闭,然而非要开启使用,请参考下网上教程进行防火墙策略开启放行设置。

        image.png

        image.png

三、云主机安全组,管理规则,限制访问外网

故障现象:拒绝云主机对访问外网。

可能原因:客户制定云主机安全组管理策略,未开启放行。

解决方法:客户查看自己云主机的安全组,查看管理规则是否设置限制访问外网,参考安全组配置案例。

四、订购的云防火墙限制访问外网

故障现象:云主机无法访问外网,拒绝连接。

可能原因:云防火墙限制访问。

解决方法:查看自己是否订购云防火墙,以及是否限制访问外网。

 

通过上述排查后,若云主机仍无法访问外网,请您记录检查过程各步骤的排查结果、相关日志信息或截图,然后联系移动云服务台提供技术支持。

 

 

本文档内容整理自移动云官方帮助中心(查看原文),仅供参考。