一、云主机挂载/卸载云硬盘常见问题
- 在控制台挂载/卸载云硬盘失败
- 在控制台挂载云硬盘,一直显示正在挂载中
- Linux云主机重启系统之后,发现数据盘消失
- 初始化云主机系统后,挂载的数据盘消失
- 已经挂载了几块云硬盘,继续挂载时报错,无法挂载
- 控制台挂载的三块硬盘在云主机内只显示两块
- 云硬盘200G挂载后只有167G可用
二、以上7种情况的排查思路
1. 在移动云控制台界面操作挂载/卸载失败
故障现象:在控制台操作挂载/卸载云硬盘显示操作失败。
可能原因:移动云业务阻塞或异常。
解决方法:请直接联系移动云服务台提供技术支持。
2. 在控制台挂载云硬盘,一直显示正在挂载中
故障现象:在控制台挂载/卸载云硬盘时一直显示挂载中。
可能原因:移动云业务阻塞或异常。
解决方法:请直接联系移动云服务台提供技术支持。
3. Linux云主机重启系统之后,发现数据盘消失
故障现象:Linux云主机重启后挂载的数据盘消失。
可能原因:
(1)云主机没有设置系统启动自动挂载硬盘,因为此前在操作挂载数据盘的时候没有将挂载信息写入到/etc/fstab中,导致重启云主机之后系统没有自动挂载数据盘。
(2)重启操作系统后,外挂磁盘掉线,驱动管理内显示ISCSI设备未启用。
解决方法:
(1)设置虚机启动自动挂载:将自动挂载信息添加至/etc/fstab文件,以/dev/xvdb1 盘为例设置启动时自动挂载到/mnt 目录。
echo '/dev/xvdb1/mnt ext3 defaults 0 0' >> /etc/fstab
或者手动vi修改/etc/fstab文件,将自动挂载内容添加至文件:
(2)启用外挂磁盘的ISCSI设备,重新激活磁盘。
4. 初始化云主机系统后,挂载的数据盘消失
故障现象:初始化云主机系统后,挂载的数据盘消失。
可能原因:因为初始化系统盘会重置/etc/fstab文件,导致初始化之后系统启动没有自动挂载数据盘。
解决方法:需要手动添加挂载信息到/etc/fstab文件中,参考问题3。
5. 已经挂载了几块云硬盘,继续挂载时报错,无法挂载
故障现象:控制台报错,无法挂载。
可能原因:检查云主机盘符是否冲突,挂载点是否使用。
解决方法:重启云主机进行重新挂载,如无法自行判断请联系移动云服务台提供技术支持。
6. 控制台挂载的三块硬盘在云主机内只显示两块
故障现象:控制台挂载的三块硬盘在云主机内只显示两块。
可能原因:该硬盘挂载失败后,云主机重装后就会出现这种问题。
解决方法:在移动云控制台点击查看该硬盘详情后,重新挂载即可。
7. 云硬盘200G挂载后只有167G可用
故障现象:云硬盘200G挂载后只有167G可用。
可能原因:挂载后的云硬盘实际可用空间确实小于订购大小200G,原因是系统的分页文件占用空间。
解决方法:查看需要选择显示隐藏文件并取消勾选隐藏保护操作系统文件。