环境配置及软件安装失败

本文提供移动云帮助中心的核心功能操作指引及常见问题解决方案。

云主机无法安装软件主要的5种异常情况

  1. 云主机本地网络异常
  2. DNS服务器解析异常
  3. yum源配置有误
  4. NET Framework安装失败
  5. msi后缀安装包安装失败

接下来,本文将具体给出这五种情况的排查思路和操作细节,部分情况需区分Linux和Windows操作系统。

情况一:云主机本地网络异常

故障现象:云主机本地无法访问外网。

可能原因:网卡驱动未开启或网卡配置有问题。

解决方法:检查网卡驱动,尝试重新安装驱动或者代理设置等。 

情况二:DNS服务器解析异常(Linux/windows)

故障现象:云主机可以ping通外网,但无法通过域名访问外网。

可能原因:没有指定DNS服务器或指定的DNS服务器不可用,或者UDP 53号端口流出方向安全组/云防火墙未放通。

解决方法:手工设置指定的DNS服务器并检查UDP 53号端口流出方向安全组/云防火墙是否放通。

Linux操作系统:

    1) 执行以下命令。

ping mirror.centos.org

     DNS解析正常显示:

     

    DNS解析异常显示:

   

    2) 通过命令:vim /etc/resolv.conf,添加nameserver 114.114.114.114。

   

    3) 执行以下命令,观察输出是否正常。

ping mirror.centos.org

    4) 检查云主机关联的安全组中,是否放通了流出方向的UDP 53端口的安全组规则,如没有的话需要放通(建议安全组流出方向端口全部放通)详情请参考:创建安全组规则。

   

    5) 检查VPC下面的云防火墙(如果有开通云防火墙的话)是否放通DNS服务UDP协议的53号端口,如下图样例。

Windows操作系统:

    1) 打开cmd命令行,执行以下命令。

ping mirror.centos.org(或其他熟悉网站)

    DNS解析正常显示:

   

    DNS解析异常显示:

   

    2) 通过打开【网络共享中心】> 选择【更改适配器设置】> 右键【本地连接】,打开【属性】> 选择【internet协议版本4】,在DNS服务器的修改模块中,选择使用下面的DNS服务器地址,分别填入114.114.114.114和8.8.8.8。

   

    3) 排查安全组和云防火墙,同Linux云主机。

情况三:yum源配置有误(Linux)

故障现象:yum源找不到对应的仓库。

可能原因:没有配置好yum源。

解决方法:重新配置yum源。

说明
移动云默认会根据您安装的操作系统自动匹配对应的Yum源。例如,当系统为CentOS时,将使用其官方源;若为Bclinux,则选用移动云镜像源。您也可以根据实际需要,随时自行调整配置。

    1) 执行以下命令,进入yum源目录。

cd /etc/yum.repos.d

    2) 执行以下命令,备份yum源。

mkdir bak1; find . -maxdepth 1  -type f -exec mv {}  ./bak1/   \;

    3) 新建yum源,打开 https://mirrors.cmecloud.cn/ ,按云主机系统打开目录,根据访问路径生成yum源。

    命令:vim new.repo,粘贴上述复制内容,保存退出

    命令:yum clean all

    命令:yum makecache

   

情况四:NET Framework安装失败(Windows)

故障现象:用户在Windows 2008 R2和Windows 2012 系统上安装.net 2.0、 .net 3.5和 .net 4.0遇到了失败的情况。

可能原因:虚拟内存未开启、服务器Windows Update更新源问题、程序版本兼容性问题。

解决方法:

    1) 使用微软.Net Framework清理工具。

    请参考微软官方文档,使用该工具后重新安装测试,要求配置服务器至少2G虚拟内存。《Microsoft .NET Framework 修复工具可用》

    2) 配置Windows官方更新源。可以尝试使用微软官方更新源,请参考如下步骤修改。

        a) 打开【运行】。

        b) 输入 gpedit.msc。

        c) 在组策略编辑器中,依次打开【计算机配置】> 【管理模板】> 【Windows 组件】> 【Windows Update】。

        d) 打开配置自动更新,默认选项为 2-通知下载并通知安装。选择该选项后,您会收到通知,然后可以手动安装需要的更新。

说明
如果您希望手动管理更新的配置,请选择 5-允许本地管理员选择设置 或者“未配置”。
如果您选择“已禁用”,在需要 Windows Update 上的任何可用更新时,必须自行下载并手动安装该更新。

        e) 打开指定 Intranet Microsoft 更新服务位置,将更新源设置为“未配置”,使用微软官方更新源测试。

        f) 打开允许自动更新立即安装默认,选项为“已禁用”。选择该选项后,系统不会自动安装更新。您可以选择“已启用”允许系统自动安装。

注意
内修改图中框选的任何一条组策略后,您需要以管理员身份打开 CMD,并运行gpupdate /force使修改项生效
 

     3) 解决版本兼容性问题。

    可以采用如下步骤删除较老版本进行测试。

        a) 点击【开始】>【控制面板】>【程序和功能】。

       

        b) 在程序列表中,排查是否已安装了该程序的其他版本,如果有,先进行卸载。

       

        c) 使用更高版本的.NET Framework 4.5再次安装部署测试,程序安装成功。

       

情况五:msi后缀安装包安装失败(Windows)

故障现象:双击安装包后提示"Windows Installer"错误

可能原因: 系统服务中的"Windows Installer"服务被禁用

解决方法: 处理方法如下:

    1) 点击【开始】>【运行】> 输入 services.msc,打开【服务】。

   

    2) 找到"Windows Installer"服务。   

   

 

    3) 鼠标双击打开【服务】,将启动类型改为自动,点击【确定】。

   

 

    4) 鼠标右键再次点击"Windows Installer",选择【启动】。服务启动后,在安装.msi 的安装包就可以了。

   

通过上述排查后,若问题仍未解决,请您记录检查过程各步骤的排查结果、相关日志信息或截图,然后联系移动云服务台提供技术支持。

本文档内容整理自移动云官方帮助中心(查看原文),仅供参考。