Windows云主机异常访问自查

本文提供移动云帮助中心的核心功能操作指引及常见问题解决方案。

背景信息

Windows云主机远程访问方式

远程桌面是微软公司为了方便网络管理员管理维护服务器而推出的一项服务。从Windows 2000 server版本开始引入,网络管理员使用远程桌面连接程序连接到网络任意一台开启了远程桌面控制功能的计算机上,就好比自己操作该计算机一样,运行程序,维护数据库等。

远程桌面仅适用于Windows系统登录Windows系统,且默认远程端口是3389,默认登录名为administrator。

为了避免您的云主机中病毒,导致数据丢失、被勒索情况,建议正式部署应用前,做好云主机安全加固:

    1. 定期对云主机、云硬盘备份,对于重要数据建议进行本地备份,详情请参考:

云服务器备份开通

云硬盘备份开通

    2. 对云主机进行安全加固,如修改远程登录端口、禁止administrator用户登录、合理设置安全组防火墙等,详情请参考:

如何给Windows云主机进行加固

    3. 订购移动云安全产品防护云主机。

    4. 云主机无法远程登录时,请先参照:云主机无法远程登录进行排查,除此之外可能还存在以下情况。

情况一 Windows组策略允许或拒绝特定用户登录排查

场景一:未配置允许远程登录权限。

在开始菜单输入"gpedit.msc"(不含引号)并按回车键,打开“组策略编辑器”,依次展开【计算机配置】>【Windows配置】 >【安全设置 】>【本地策略】>【用户权限分配】。

在右侧的【策略】中,找到【允许远程桌面服务登录】,双击查看要允许远程桌面登录的账户是否在列表中。

解决方案

如果需要允许其他账户远程登录,点击【添加用户或组】,在弹出的窗口输入账户名称,依次点击确定。

测试使用刚才添加的账户进行远程登录,登录成功。

场景二:未修改拒绝远程登录权限。

在开始菜单输入"gpedit.msc"(不含引号)并按回车键,打开“组策略编辑器”,依次展开【计算机配置】>【Windows配置】>【安全设置 】>【本地策略】>【用户权限分配】。

在右侧的【策略】中,找到【拒绝通过远程桌面服务登录】,双击查看要允许远程桌面登录的账户是否在列表中。

解决方案

如果确认想要远程桌面登录的账户在列表中,需要将该账户从列表中删除,并重启云主机。

测试使用刚才添加的账户进行远程登录,登录成功。

情况二 远程访问Windows出现“出现身份验证错误,要求的函数不受支持”

因为CredSSP出现漏洞,如果用户的Windows 2008/2012云主机进行了更新,本地登录云主机(Windows 2008/2012)有可能会出现如下图所示报错:

那是因为Windows 2008/2012云主机进行了更新,而客户本地没更新所导致的,详细可以见下表:

解决方案

提供解决方案如下,请客户按照步骤进行配置:

    1. 调出运行,输入gpedit.msc打开本地组策略编辑器。

     

    2. 打开界面如下图。

     

    3. 依次展开【计算机配置】>【管理模板】>【系统】>【凭据分配】,设置名称: 加密 Oracle 修正。

     

    4. 然后右键编辑,改为启用,级别为易受攻击。

     

    5. 确定保存配置后就能顺利进行远程登录了。 

情况三 远程访问Windows出现“远程服务无法启用”

远程访问Windows云主机时,出现

 

此时会有两种可能性:

    1. 客户在云主机内下载了360等安全软件,并且在优化时被该软件禁用了远程服务这一功能,就会出现这种情况。

    2. 客户云主机被暴力破解扫描。

解决方案

    方案一:请您通过VNC登录云主机,进入360等安全软件的设置界面允许远程桌面服务开机启动,在开机优化界面对该服务进行忽略即可。

    方案二:请您参考如何给Windows云主机进行加固进行安全防护。

情况四 Windows云主机被暴力破解

Windows云主机被暴力破解扫描,系统安全策略将账号锁定,无法远程。请您通过VNC登录云主机,右键点击【计算机】>【管理】>【计算机管理】>【事件查看器】>【Windows日志】>【安全】,可查看云主机的登录情况,如图: 

解决方案

可参考如何给Windows云主机进行加固进行安全防护。

报障信息需求

若您按照以上自查指引操作后,仍无法远程访问您的云主机,可致电移动云服务热线4001-10086-8 转4或在控制台使用在线工单进行报错,感谢您对移动云的支持。

本文档内容整理自移动云官方帮助中心(查看原文),仅供参考。